Apple zalátal bezpečnostní chyby v Safari

Po měsíci Apple opět uvolnil záplaty pro prohlížeč Safari. Celkem bylo opraveno 6 bezpečnostních chyb, z toho 4 kritické, které umožňovaly útočníkovi vzdálené spuštění libovolného kódu. Aktualizovaná verze má číslo 4.0.3.


Šest zranitelností se vztahuje k verzi pro Windows XP a Vista, pro MacOS X byly opraveny pouze 4 problémy. Tři ze zranitelností se týkají open source jádra prohlížeče WebKit, které kromě Safari používá i Google Chrome. Kromě toho byla ale opravena i zranitelnost ve funkci Top Sites. Od verze Safari 4 zobrazuje tato funkce uživateli při spuštění prohlížeče nebo otevření nové záložky náhledy často navštěvovaných webů. Útočníci ale mohou do tohoto přehledu svůj web podvrhnout, což může být zneužitelné zejména pro phishing.

Pouze ve verzi pro Windows byly záplatovány chyby související s přetečením zásobníku nebo haldy. Ke zneužití se v tomto případě daly použít speciálně upravené dlouhé řetězce, zranitelnost se objevovala také při zpracování metadat obrázků. Potíže byly se zpracováním čísel v pohyblivé řádové čárce a s pluginy, jeden z problémů umožňoval útočníkovi podvrhnout URL.

Safari dnes jako svůj primární prohlížeč používá asi 4 % uživatelů Internetu.

Safari 4.0.3 lze stáhnout buď ručně, nebo pomocí automatických aktualizačních funkcí zabudovaných ve verzi pro Windows i MacOS.

 











Komentáře