Další kritická chyba zero day v Adobe Readeru

V aktuálních verzích Acrobatu a Adobe Readeru byla objevena kritická bezpečnostní zranitelnost. Adobe přiznává, že současně se zveřejněním informace začaly probíhat i pokusy o zneužití.


Kód zneužití se již stal součástí open source nástroje pro penetrační a bezpečnostní testování Metasploit. Tento nástroj ovšem s oblibou používají i útočníci. Podle Adobe je zranitelná jak nejnovější verze 9.2 Acrobatu i Adobe Readeru, tak i všechny podporované starší verze. Problém se týká se verzí pro Windows, na Linuxu a MacOS může dojít pouze ke zhavarování aplikace, tj. chyba zde nemá bezpečnostní povahu.

Ke zneužití stačí, aby uživatel otevřel soubor PDF upravený útočníkem tak, aby došlo ke spuštění kódu. Tyto podvodné PDF dokumenty již byly zaznamenány – vzhledem k množství počítačů, na nichž je Reader nainstalován, si útočníci pochopitelně těžko tuto příležitost nechají ujít. Vlastní chyba se nachází ve zpracování JavaScriptu, pro ochranu by ho tedy mělo stačit zakázat (v lokalizovaném Readeru: Úpravy-Předvolby-JavaScript-zrušit zaškrtnutí políčka Povolit JavaScript Acrobatu). A protože se rozhodně nejedná o první (a nejspíš ani poslední) zranitelnost tohoto typu, lze vlastně toto nastavení předvolby doporučit tak jako tak.

Bezpečnostní firmy upozorňují, že až do vydání opravy ze strany Adobe je vytvoření signatur/definic, které by chránily před tímto typem útoku, nepravděpodobné, protože tento typ zneužití lze jen obtížně detekovat (probíhá přes zlib stream). Adobe plánuje vydání příští várky oprav svých nástrojů pro zpracování PDF až na 12. ledna 2010.

 











Komentáře