Flash a PHP potřebují nouzové opravy

Adobe vydalo opravu pro kritickou zranitelnost ve Flash Playeru zneužívanou k útokům na počítače s operačními systémy Windows.

Flash a PHP potřebují nouzové opravy


Mezitím se vývojáři usilovně snaží také o opravu zranitelnosti v programovacím jazyce PHP, která se objevila počátkem minulého týdne.

V případě Flash Playeru se zranitelnost týká všech dostupných verzí. S instalací nové aktualizace by tedy neměli otálet uživatelé operačních systémů Windows, Mac, Linux ani Android, a to i přesto, že se zatím ví pouze o několika případech zneužití zranitelnosti k útokům proti uživatelům Windows.

Škodlivý kód je distribuován prostřednictvím elektronických zpráv obsahujících infikovanou přílohu. Podle všeho jde o dobře cílené emaily, které obdrží pouze omezený počet jedinců. V minulosti se stalo populárním šířit viry v souborech formátu PDF. Těch útočníci využívají i v tomto případě. Kromě nich by si však měli dát uživatelé pozor také na přílohy v podobě dokumentů vytvořených v některém z programů sady MS Office.

Větší nebezpečí nicméně představují právě soubory PDF. Uživatelé se totiž mylně domnívají, že se jejich spuštěním nevystavují žádnému riziku jen proto, že jde o jednoduché textové dokumenty. Pro hackery jde přitom o ideální způsob, jak do cizího počítače protlačit svůj kód.

Novou aktualizaci by si podle Adobe měli stáhnout všichni uživatelé Windows, Linuxu a Macu, kteří nyní používají Flash Player verze 11.2.202.233 a starší. Stejně by měli učinit také uživatelé Androidu 4.x používající Flash Player 11.1.115.7 a uživatelé Androidu 2.x a 3.x s verzí 11.1.111.8. Pokud si náhodou nejste jistí, jakou verzi vlastně používáte, zavítejte na oficiální stránky Adobe.

Uživatelé webového prohlížeče Google Chrome se o aktualizaci nemusí starat, protože se jim nainstaluje automaticky díky tichému aktualizačnímu mechanismu. Stejně se opravou nemusí samozřejmě zabývat ani majitelé zařízení s mobilním systémem iOS, který Flash Player vůbec nepodporuje.

Počátkem minulého týdne také výzkumníci upozornili na zranitelnost ve skriptovacím jazyce PHP. Zajímavé na ní je hlavně to, že jde o chybu starou několik měsíců. Dlouhou dobu se o ní zajímali výzkumníci z Eindbazenu, ovšem jeden z nich o ní omylem zveřejnil informace na internetu. Zranitelnost postihuje servery konfigurované pro běh v CGI módu a může být zneužita ke zobrazení zdrojového kódu aplikací umístěných na webových stránkách nebo ke spuštění škodlivého kódu.

Krátce po zveřejnění zranitelnosti byla vydána oprava. Později se však ukázalo, že samotná aktualizace obsahuje chybu, kvůli které je oprava neúčinná. Na funkční opravě se proto v současné době stále pracuje.

Úvodní foto: © piumadaquila.com - Fotolia.com










Komentáře