Přehled nově objevených bezpečnostních děr

Dnes vám přinášíme výčet nově objevených bezpečnostních děr, jež by mohly být zneužity k útokům na počítač. V seznamu nechybí ani takové perličky jako nedostatky v operačním systému Mac OS X pro Apple či díry v internetovém prohlížeči Mozilla Firefox.



Dnes vám přinášíme výčet nově objevených bezpečnostních děr, jež by mohly být zneužity k útokům na počítač. V seznamu nechybí ani takové perličky jako nedostatky v operačním systému Mac OS X pro Apple či díry v internetovém prohlížeči Mozilla Firefox.

Několik nově objevených zranitelností v aplikacích McAfee ePolicy Orchestrator a ProtectionPilot může být vzdáleným útočníkem zneužito k převzetí kontroly nad systémem. Zranitelnost je způsobena chybou v ActiveX ovladači Sitemanager.dll při zpracovávání argumentů předávaných metodami ExportSiteList() a VerifyPackageCatalog(). Zneužití může být realizováno prostřednictvím vytvořením podmínek pro buffer overflow, a to na základě nezvykle dlouhého řetězce předaného jako argument výše zmíněným metodám. Úspěšné zneužití může vést ke spuštění škodlivého kódu. Zasaženy jsou verze McAfee ePolicy Orchestrator 3.5.0 (Patch 5 a starší), 3.6.0 (Patch 5 a starší) a 3.6.1, dále pak McAfee ProtectionPilot 1.1.1 (Patch 3 a starší) a 1.5.0.

Zranitelnosti od Applu

První ze série nových zranitelností postihujících produkty firmy Apple byla detekována v operačním systému Mac OS X, přičemž může být zneužita lokálními útočníky ke spuštění škodlivých příkazů, odepření služby, k vyzrazení citlivých informací, nebo dokonce i k obejití bezpečnostních pravidel. Chyby se vyskytují v produktech Mac OS X verze 10.3.9 (a starší) a 10.4.8 (a starší), dále Apple Mac OS X Server verze 10.3.9 (a starší) a 10.4.8 (a starší). Záplata je již k dispozici.

Další postiženou aplikací Applu je QuickTime version 7.1.4 (a starší verze), jejíž zranitelnost může být útočníkem zneužita k převzetí kontroly nad zasaženým systémem. Ke zneužití může dojít při zpracovávání agresorem modifikovaných multimediálních 3GP videosouborů, souborů MIDI nebo QuickTime, dále UDTA dat či obrázkových souborů (formáty PICT a QTIF). Řešením je přechod na QuickTime verzi 7.1.5.

Problém v Mozille

Překonání bezpečnostních opatření a převzetí kompletní kontroly nad postiženým systémem – to je možný důsledek zranitelnosti v produktech Mozilla Firefox a SeaMonkey. Příčinou problémů může být chyba při zpracování některých IMG tagů, což může být agresorem použito k obejití některých opatření v globálních preferencích a ke spuštění škodlivého kódu v případě, že uživatele přinutí navštívit zákeřné webové stránky s javascriptovým URI a SRC atributem IMG elementu. Postiženy jsou aplikace Mozilla Firefox 1.5.0.9 a 2.0.0.1 stejně jako Mozilla SeaMonkey 1.0.7. Řešením problému je přechod na novější verzi programů (1.5.0.10 nebo 2.0.0.2 v případě řešení Firefox, respektive 1.1.1 nebo 1.0.8 u aplikace SeaMonkey).

Potíže pro Trend Micro

Minimálně verze 14.10.1042 aplikace Trend Micro Antivirus (a pravděpodobně i některé další) je zasažena zranitelností, s jejíž pomocí může vzdálený útočník vytvořit podmínky pro odepření služby, a to tak, že vytvoří modifikovaný UPX soubor, který při antivirové kontrole inkriminovaným programem způsobí nekorektní dělení nulou v kernelovém ovladači VsapiNT.sys. Důsledkem toho je pád celého programu. Oprava již byla vydána.

Apache Tomcat Connector

Vzdálení útočníci mohou kompromitovat webový server, pokud obsahuje zranitelnou verzi Apache Tomcat Connectoru. Zranitelná jsou varianty Apache Tomcat Connector (mod_jk) 1.2.19 nebo 1.2.20 a Apache Tomcat verze 4.1.34 nebo 5.5.20. Důsledkem zneužití chyby je buffer overflow v knihovně mod_jk při zpracovávání neobvykle dlouhých URL metodou „map_uri_to_worker()“. Řešení problému je jednoduché: aktualizace knihovny mod_jk na verzi 1.2.21.










Komentáře