Stará chyba v shellu Bash postihuje půl miliardy zařízení

Experti na internetu objevili bezpečnostní riziko, které postihuje stovky milionů počítačů, serverů a dalších zařízení s operačními systémy typu Unix, Linux nebo OS X.

Stará chyba v shellu Bash postihuje půl miliardy zařízení


Díra byla objevena v jednom z nejrozšířenějších prostředí příkazového řádku známém jako Bash, který je součástí mnoha unixových a linuxových systémů, stejně jako operačního systému pro OS X od Applu. Chyba, jíž experti přezdávají „Shellshock“, může být využita k získání vzdálené kontroly nad téměř jakýmkoli systémem obsahujícím Bash. Podle některých odborníků je nové riziko mnohem nebezpečnější, než Heartbleed, o němž se hodně psalo v dubnu tohoto roku.

„Zatímco Heartbleed umožňoval zjistit o uživateli co nejvíc věcí, Shellshock umožňuje převzít přímou kontrolu nad systémem,“ uvedl profesor Alan Woodward z University of Surrey. Hearbleed ohrožoval asi půl milionu počítačů na celém světě, Shellshock se však podle konzervativních odhadů expertů týká minimálně pěti set milionů zařízení. Problém je o to závažnější, že řada webových serverů používá software Apache, který využívá právě Bash.

Bash (Bourne-Again SHell) je příkazový řádek na mnoha počítačích s Unixem. Unix je operační systém, na němž je postavena nebo se v něm inspiruje řada dalších OS – například Linux nebo OS X. O novém riziku na svých stránkách informoval i mimo jiné US Computer Emergency Readiness Team (US-Cert) s tím, že správci by měli co nejdříve použít bezpečnostní opravy. Jiní bezpečnostní experti však varovali před tím, že aktualizace jsou „neúplné“ a počítače plně nezabezpečí.

Shellshock je na škále od jedné do deseti označen jako desítka, tudíž už ani nemůže být více nebezpečný. Jednak je zde značný počet uživatelů, kteří mohou být postiženi, hlavně je však pro Shellshock již volně dostupný exploit a ví se, že kyberzločinci aktivně hledají webové stránky, které by byly vhodné k provedení útoku. Servery nyní podle expertů chrání především fakt, že kybernetičtí útočníci jsou líní a pouze kopírují to, co již jiní vymysleli. Hledání exploitů je těžká práce, tudíž většina útočníků pouze využívá již publikované informace.

I když bezpečnostní experti ze společnosti Rapid7 ohodnotili Bash jako 10/10 co do závažnosti, označili jej jako „málo“ sofistifikovaný. „S použitím této díry útočníci mohou potenciálně převzít kontrolu nad operačním systémem, přistupovat k citlivým informacím, provádět změny a tak dále,“ uvedl Tod Beardsley z Rapid7. Jak uvedla společnost Kaspersky Labs, zranitelnost již byla kyberzločinci zneužita k napadení webových serverů. Běžným domácím uživatelům, kteří mají obavy z bezpečnosti, pak profesor Woodward doporučuje sledovat webové stránky výrobců hardwaru, především směrovačů, a čekat na aktualizace.

 

Úvodní foto: © chanpipat - Fotolia.com










Komentáře