Starší verze OS Android jsou v ohrožení webovými útoky

Bezpečnostní odborník vytvořil vlastní škodlivý kód s cílem upozornit na zranitelnost v mobilním operačním systému Android.


Zranitelnost se nachází ve verzi 2.1 a starších. Upozornil na ní bezpečnostní výzkumník MJ Keith na konferenci  HouSecCon v americkém Houstonu. Možné riziko zneužití demonstroval pomocí vlastního kódu, který mu umožňuje spustit jednoduchý příkazový řádek v systému Android poté, co uživatel navštíví stránku s tímto škodlivým obsahem.

Chyba, kterou Keithův útok zneužívá, se nachází v jádru WebKit prohlížeče používaného Androidem. Google o této chybě prý ví. „Problému s Webkitem jsme si vědomi, týká se však pouze starších verzí,“ uvedl Jay Nancarrow, mluvčí společnosti. Android 2.2, který v současné době běží na 36 % přístrojů Android, tedy v ohrožení není. Pro majitele starších telefonů jako G1 či HTC Droid Eris, u kterých není možné provést aktualizaci, však zranitelnost určité riziko představovat může.

Podle Keitha by sice případný útočník asi nemohl chybu zneužít ke čtení a posílání textových zpráv či k volání, ale mohl by získat třeba uložené fotografie či historii prohlížených stránek. Své poznatky, včetně kódu, již Keith zveřejnil na stránkách Exploit Database.

Nejde rozhodně o první ani poslední zranitelnost mobilních operačních systémů, problém však je, že s rostoucí popularitou smartphonů roste i možné riziko jejich napadení škodlivým kódem. Google, ale i další výrobci, se proto budou muset více zaměřit na ochranu uživatelů před těmito případnými útoky.











Komentáře