Zneužití chyb zero-day v Javě se rychle rozšiřuje

Nástroj Blackhole přidal nový kód, který umožňuje zneužití neopravených chyb v Javě 7.

Zneužití chyb zero-day v Javě se rychle rozšiřuje


Útočníci, kteří využívají dvě nedávno odhalená zranitelná místa v Javě 7, označované obecně jako „zero-day“, rychle rozšiřují svůj rozsah, oznámili ve čtvrtek bezpečnostní experti.

V úterý se k řadě rad, doporučujících současnou verzi Javy vypnout, přidala i Mozilla, která stojí za prohlížečem Firefox. Společnost je připravena plugin automaticky zablokovat, ale zatím toto řešení odkládá.

Společnosti, které se zabývají bezpečností, jako například FireEye nebo Websence, v úterý oznámily, že bylo zneužití přidáno do známého nástroje, který využívají hackeři – Blackhole. Ten zkouší všechna známá zneužití, dokud nenarazí na takové, které v konkrétním počítači funguje.

Zařazení zneužití těchto nově objevených chyb do Blackhole ve středu komentoval výzkumník Atif Mushtaq: „Po té, co jsem viděl spolehlivost tohoto útoku, nemám žádné pochyby o tom, že ztráty budou během několika hodin v tisících.“

Ředitel výzkumu bezpečnosti ve Websence Petr Runald ve čtvrtek prohlásil, že jeho tým našel více než 100 unikátních domén, které slouží novému zneužití v Javě. „Očekáváme, že počet stránek kompromitovaných zneužitím těchto nově objevených chyb v následujících dnech výrazně vzroste,“ podotkl Runald.

Michael Coates, ředitel bezpečnosti v Mozille, vyzval uživatele Firefoxu, aby plugin Javy v prohlížeči vypnuli, dokud Oracle problém nevyřeší. Vývojáři Firefoxu jsou připraveni plugin zablokovat – Mozilla má možnost rozšíření a pluginy, které mohou způsobit problémy s bezpečností nebo výkonem, přidat do seznamu blokovaných. Před zablokováním rozšíření Firefox uživatele vždy automaticky upozorní. „Oracle pravděpodobně chybu opraví v říjnu při plánované údržbě, to dává škůdcům spoustu času k profitu, pokud je mezitím nezablokujeme,“ konstatoval Daniel Veditz, bezpečnostní technik Firefoxu. Oracle plánuje pravidelnou údržbu na 12. října.

Nejvíce jsou ohrožena zařízení s operačním systémem Windows, ale pokud hackeři integrují nové chyby i do malwaru, který je specifický pro Mac, mohli by být ohroženi i uživatelé OS X.

Apple přestal Javu dodávat jako součást OS X počátkem roku 2011 ve verzi Lion, letošní Mountain Lion Javu opomíjí také, ale uživatelé mohou mít Javu 7 nainstalovanou. Pokud webový prohlížeč narazí na applet Javy, OS X nabídne instalaci Javy 7. Lidé se starší verzí Snow Leopard (2009) nebo Leopard (2007) v ohrožení nejsou, Java 7 totiž vyžaduje novější verzi tohoto systému.

Úvodní foto: © lassedesignen - Fotolia.com










Komentáře