Firefox 4: Hardwarová akcelerace naráží na potíže s ovladači grafických karet

Mozilla přesvědčuje uživatele, aby aktualizovali ovladače svých grafických karet.


Řada z nich má totiž v PC nainstalované starší drivery, které ovšem nefungují správně při hardwarové akceleraci vykreslování obsahu.

Benoit Jacob, člen vývojového týmu Mozilly, k tomu říká, že v seznamu statistik chyb a pádů Firefoxu 4 mají problémy s ovladači grafické karty poměrně významnou pozici. Jedná se o nový zdroj možných chyb a během testovací beta fáze proto Mozilla selektivně vypnula ve Firefoxu 4 některé funkce starších ovladačů, aby k chybám nedocházelo. To má ale za následek, že hardwarová akcelerace vykreslování obsahu na takových ovladačích nefunguje, jak by měla. Konkrétně existuje něco jako seznam problematických ovladačů grafických karet, který si Firefox načítá. Pokud je ovladač na seznamu, pak bude hardwarová akcelerace zablokována.

Hardwarová akcelerace má za cíl při surfování odlehčit CPU a přenést část jeho úloh na jádra grafické karty. Mozilla tuto funkci začlenila do vyvíjeného Firefoxu 4 v minulém roce, ale vzhledem k tomu, že jde o novinku, narazila na množství potíží, které prodloužily vývoj samotného prohlížeče. S hardwarovou akcelerací přišel jako první Microsoft v betě svého IE9, ale ten nefunguje pod Windows XP, zatímco Mozilla chce nadále podporovat i tento starší operační systém, který je stále nejrozšířenější. Využívá k tomu Direct3D API místo novějších API, která jsou dostupná jen ve Vistě a Windows 7.

K funkčnosti hardwarové akcelerace podle Jacoba potřebují uživatelé pro grafické karty nVidia ovladač ve verzi 257.21 a novější a pro ATI 10.6 a novější. Co se týká grafických čipů Intelu, tam jen Mozilla neurčitě poznamenává, že je nutný nový ovladač. Bohužel ne všichni uživatelé mají možnost ovladače grafických karet aktualizovat, např. díky omezeným právům nebo dokonce kvůli omezením od výrobce. Co se týká uživatelů počítačů od Applu, zde Firefox pro hardwarovou akceleraci využívá OpenGL a vyžaduje Mac OS X 10.6.3 či novější. Grafické karty, které OpenGL nepodporují, jako např. ATI Radeon X1000 a starší, GeForce FX a starší či Intel GMA 950 a starší, nejsou schopny tuto technologii na Macu využít.

Podle posledních informací z Mozilly bychom se release candidate verze Firefoxu 4 měli dočkat co nejdříve, možná již tento týden.











Komentáře